import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9]{1,}?[_-]?[a-z0-9]{1,}?\\@[a-z0-9]{1,}?\\-?[a-z0-9]{1,}?\\.[a-z]{2,}$";
final String string = "mymail@site.ru\n"
+ "my-mail@site.ru\n"
+ "-mymail@site.ru\n"
+ "mymail-@site.ru\n"
+ "my---mail@site.ru\n"
+ "my--mail---test@site.com\n"
+ "mail@-site-.ru\n"
+ "mymail@site.__\n"
+ "mail@site.r\n"
+ "a@b.moscow\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}