// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9]{1,}?[_-]?[a-z0-9]{1,}?\@[a-z0-9]{1,}?\-?[a-z0-9]{1,}?\.[a-z]{2,}$").unwrap();
let string = "mymail@site.ru
my-mail@site.ru
-mymail@site.ru
mymail-@site.ru
my---mail@site.ru
my--mail---test@site.com
mail@-site-.ru
mymail@site.__
mail@site.r
a@b.moscow
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}