import re
regex = re.compile(r"^[a-z0-9]{1,}?[_-]?[a-z0-9]{1,}?\@[a-z0-9]{1,}?\-?[a-z0-9]{1,}?\.[a-z]{2,}$", flags=re.MULTILINE)
test_str = ("mymail@site.ru\n"
"my-mail@site.ru\n"
"-mymail@site.ru\n"
"mymail-@site.ru\n"
"my---mail@site.ru\n"
"my--mail---test@site.com\n"
"mail@-site-.ru\n"
"mymail@site.__\n"
"mail@site.r\n"
"a@b.moscow\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")