#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|(?<!^)\G)(?!$)(?>\h*,\h*\K)?+((?:(?:[^",\n]|\\.)*?|"(?:[^\\\n"]*+|"[^\\\n"]*"|\\.)*"|[^"\n]+"[^"\n]*))(?=\h*+(?:,|$))"
Local $sString = "for this. , OK \"it\" is,"hmmm", "item "three"", a, yup" & @CRLF & _
"" & @CRLF & _
"one, tw"o, three", "four, five", "six", "s"e,"v,"e,"n", \"eight, "nine, "ten", eleven"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")