re = /(?:^|(?<!^)\G)(?!$)(?>\h*,\h*\K)?+((?:(?:[^",\n]|\\.)*?|"(?:[^\\\n"]*+|"[^\\\n"]*"|\\.)*"|[^"\n]+"[^"\n]*))(?=\h*+(?:,|$))/m
str = 'for this. , OK \\"it\\" is,"hmmm", "item "three"", a, yup
one, tw"o, three", "four, five", "six", "s"e,"v,"e,"n", \\"eight, "nine, "ten", eleven'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end