const regex = /(?:^|(?<!^)\G)(?!$)(?>\h*,\h*\K)?+((?:(?:[^",\n]|\\.)*?|"(?:[^\\\n"]*+|"[^\\\n"]*"|\\.)*"|[^"\n]+"[^"\n]*))(?=\h*+(?:,|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|(?<!^)\\G)(?!$)(?>\\h*,\\h*\\K)?+((?:(?:[^",\\n]|\\\\.)*?|"(?:[^\\\\\\n"]*+|"[^\\\\\\n"]*"|\\\\.)*"|[^"\\n]+"[^"\\n]*))(?=\\h*+(?:,|$))', 'gm')
const str = `for this. , OK \\"it\\" is,"hmmm", "item "three"", a, yup
one, tw"o, three", "four, five", "six", "s"e,"v,"e,"n", \\"eight, "nine, "ten", eleven`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}