$re = '/(?:^|(?<!^)\G)(?!$)(?>\h*,\h*\K)?+((?:(?:[^",\n]|\\\\.)*?|"(?:[^\\\\\n"]*+|"[^\\\\\n"]*"|\\\\.)*"|[^"\n]+"[^"\n]*))(?=\h*+(?:,|$))/m';
$str = 'for this. , OK \\"it\\" is,"hmmm", "item "three"", a, yup
one, tw"o, three", "four, five", "six", "s"e,"v,"e,"n", \\"eight, "nine, "ten", eleven';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);