using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(?<!^)\G)(?!$)(?>\h*,\h*\K)?+((?:(?:[^"",\n]|\\.)*?|""(?:[^\\\n""]*+|""[^\\\n""]*""|\\.)*""|[^""\n]+""[^""\n]*))(?=\h*+(?:,|$))";
string input = @"for this. , OK \""it\"" is,""hmmm"", ""item ""three"", a, yup
one, tw""o, three"", ""four, five"", ""six"", ""s""e,""v,""e,""n"", \""eight, ""nine, ""ten"", eleven";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}