import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|(?<!^)\\G)(?!$)(?>\\h*,\\h*\\K)?+((?:(?:[^\",\\n]|\\\\.)*?|\"(?:[^\\\\\\n\"]*+|\"[^\\\\\\n\"]*\"|\\\\.)*\"|[^\"\\n]+\"[^\"\\n]*))(?=\\h*+(?:,|$))";
final String string = "for this. , OK \\\"it\\\" is,\"hmmm\", \"item \"three\"\", a, yup\n\n"
+ "one, tw\"o, three\", \"four, five\", \"six\", \"s\"e,\"v,\"e,\"n\", \\\"eight, \"nine, \"ten\", eleven";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}