using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"}\s*catch .*? {(.*?)}";
string substitution = @"$1";
string input = @"#Any code
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler("", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, "", ex);
}
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler(""Custom"", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, "", ex);
}";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}