$re = '/}\s*catch .*? {(.*?)}/s';
$str = '#Any code
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler("", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, "", ex);
}
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler("Custom", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, "", ex);
}';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;