// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)}\s*catch .*? {(.*?)}").unwrap();
let string = "#Any code
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler(\"\", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, \"\", ex);
}
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler(\"Custom\", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, \"\", ex);
}";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}