const regex = /}\s*catch .*? {(.*?)}/sg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('}\\s*catch .*? {(.*?)}', 'sg')
const str = `#Any code
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler("", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, "", ex);
}
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler("Custom", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, "", ex);
}`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);