re = /}\s*catch .*? {(.*?)}/
str = '#Any code
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler("", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, "", ex);
}
try
{
#Any code
if(true)
{
// Hello here
}
}
catch (Exception ex)
{
throw new ExceptionHandler("Custom", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, "", ex);
}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result