import re
regex = re.compile(r"}\s*catch .*? {(.*?)}", flags=re.DOTALL)
test_str = ("#Any code\n"
" try\n"
" {\n"
" #Any code\n"
" if(true)\n"
" {\n"
" // Hello here\n"
" }\n"
" }\n"
" catch (Exception ex)\n"
" {\n"
" throw new ExceptionHandler(\"\", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, \"\", ex);\n"
" }\n\n"
" try\n"
" {\n"
" #Any code\n"
" if(true)\n"
" {\n"
" // Hello here\n"
" }\n"
" }\n"
" catch (Exception ex)\n"
" {\n"
" throw new ExceptionHandler(\"Custom\", ExceptionType.UnexceptedException, ExceptionSeverity.Error, null, \"\", ex);\n"
" }")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)