#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)[^\pL\pN\\,]+|\B,\B"
Local $sString = ""bananaã€xxã€tyuã€fdg dfgdfã€dfgfdgdã€dfdfgã€dfgdg ã€cvbcvb", dfdgd" & @CRLF & _
" sdfs. 2te. 459,202' dfg/ dfg, bvn, bn, wqe。uyo." & @CRLF & _
" yuo, "yuouyã€yuoyã€jlkjã€nmj , tryrtã€346,457ã€ghã€325352 ã€fghfg""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)