// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)[^\pL\pN\\,]+|\B,\B").unwrap();
let string = "\"bananaã€xxã€tyuã€fdg dfgdfã€dfgfdgdã€dfdfgã€dfgdg ã€cvbcvb\", dfdgd
sdfs. 2te. 459,202' dfg/ dfg, bvn, bn, wqe。uyo.
yuo, \"yuouyã€yuoyã€jlkjã€nmj , tryrtã€346,457ã€ghã€325352 ã€fghfg\"";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}