re = /[^\pL\pN\\,]+|\B,\B/
str = '"bananaã€xxã€tyuã€fdg dfgdfã€dfgfdgdã€dfdfgã€dfgdg ã€cvbcvb", dfdgd
sdfs. 2te. 459,202\' dfg/ dfg, bvn, bn, wqe。uyo.
yuo, "yuouyã€yuoyã€jlkjã€nmj , tryrtã€346,457ã€ghã€325352 ã€fghfg"'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result