import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"[^\pL\pN\\,]+|\B,\B"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"bananaã€xxã€tyuã€fdg dfgdfã€dfgfdgdã€dfdfgã€dfgdg ã€cvbcvb", dfdgd
sdfs. 2te. 459,202' dfg/ dfg, bvn, bn, wqe。uyo.
yuo, "yuouyã€yuoyã€jlkjã€nmj , tryrtã€346,457ã€ghã€325352 ã€fghfg"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)