package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:copyright[ \t]*)?(?:©|\(c\)|&#(?:169|xa9;)|©)[ \t]+(?:19|20)[0-9]{2} Company(?: All Rights Reserved)?`)
var str = `Copyright © 2019 Company All Rights Reserved
© 2019 Company All Rights Reserved
© 2019 Company
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}