const regex = /(?:copyright[ \t]*)?(?:©|\(c\)|&#(?:169|xa9;)|©)[ \t]+(?:19|20)[0-9]{2} Company(?: All Rights Reserved)?/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:copyright[ \\t]*)?(?:©|\\(c\\)|&#(?:169|xa9;)|©)[ \\t]+(?:19|20)[0-9]{2} Company(?: All Rights Reserved)?', 'gmi')
const str = `Copyright © 2019 Company All Rights Reserved
© 2019 Company All Rights Reserved
© 2019 Company
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}