import re
regex = re.compile(r"(?:copyright[ \t]*)?(?:©|\(c\)|&#(?:169|xa9;)|©)[ \t]+(?:19|20)[0-9]{2} Company(?: All Rights Reserved)?", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("Copyright © 2019 Company All Rights Reserved\n"
"© 2019 Company All Rights Reserved\n"
"© 2019 Company\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")