re = /(?:copyright[ \t]*)?(?:©|\(c\)|&#(?:169|xa9;)|©)[ \t]+(?:19|20)[0-9]{2} Company(?: All Rights Reserved)?/mi
str = 'Copyright © 2019 Company All Rights Reserved
© 2019 Company All Rights Reserved
© 2019 Company
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end