#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?<=\s)(\w+)(?=\()(.*\{\n.*)(OLD_LOG;)(.*)(\n\})"
Local $sString = "returnType functionName(parameters){" & @CRLF & _
" OLD_LOG;" & @CRLF & _
" //stuff to do" & @CRLF & _
"" & @CRLF & _
"}"
Local $sSubst = "\1 \2NEW_LOG("\1");\n\4\n END_LOG();\5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)