use strict;
my $str = 'returnType functionName(parameters){
OLD_LOG;
//stuff to do
}';
my $regex = qr/(?<=\s)(\w+)(?=\()(.*\{\n.*)(OLD_LOG;)(.*)(\n\})/sp;
my $subst = '\\1 \\2NEW_LOG("\\1");\\n\\4\\n END_LOG();\\5';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";