using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s)(\w+)(?=\()(.*\{\n.*)(OLD_LOG;)(.*)(\n\})";
string substitution = @"\1 \2NEW_LOG(""\1"");\n\4\n END_LOG();\5";
string input = @"returnType functionName(parameters){
OLD_LOG;
//stuff to do
}";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}