$re = '/(?<=\s)(\w+)(?=\()(.*\{\n.*)(OLD_LOG;)(.*)(\n\})/s';
$str = 'returnType functionName(parameters){
OLD_LOG;
//stuff to do
}';
$subst = "\1 \2NEW_LOG(\"\1\");\n\4\n END_LOG();\5";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;