re = /(?<=\s)(\w+)(?=\()(.*\{\n.*)(OLD_LOG;)(.*)(\n\})/
str = 'returnType functionName(parameters){
OLD_LOG;
//stuff to do
}'
subst = '\\1 \\2NEW_LOG("\\1");\\n\\4\\n END_LOG();\\5'
result = str.sub(re, subst)
# Print the result of the substitution
puts result