const regex = /(?<=\s)(\w+)(?=\()(.*\{\n.*)(OLD_LOG;)(.*)(\n\})/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)(\\w+)(?=\\()(.*\\{\\n.*)(OLD_LOG;)(.*)(\\n\\})', 's')
const str = `returnType functionName(parameters){
OLD_LOG;
//stuff to do
}`;
const subst = `\1 \2NEW_LOG("\1");\n\4\n END_LOG();\5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);