#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^stop.*"
Local $sString = "stop to the end of line" & @CRLF & _
"stop" & @CRLF & _
"stopping with line" & @CRLF & _
"stop and so on" & @CRLF & _
"hey stop select random" & @CRLF & _
"not the start of line stopping but the end" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")