using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^stop.*";
string input = @"stop to the end of line
stop
stopping with line
stop and so on
hey stop select random
not the start of line stopping but the end
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}