re = /^stop.*/
str = 'stop to the end of line
stop
stopping with line
stop and so on
hey stop select random
not the start of line stopping but the end
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end