import re
regex = re.compile(r"^stop.*")
test_str = ("stop to the end of line\n"
"stop\n"
"stopping with line\n"
"stop and so on\n"
"hey stop select random\n"
"not the start of line stopping but the end\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")