// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^stop.*").unwrap();
let string = "stop to the end of line
stop
stopping with line
stop and so on
hey stop select random
not the start of line stopping but the end
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}