$re = '/^stop.*/';
$str = 'stop to the end of line
stop
stopping with line
stop and so on
hey stop select random
not the start of line stopping but the end
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);