using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h4>(?:(?!<\/?h4>).)*?<\/h4>(?!.*?<div class='content'>)";
string input = @"<div class='content'>
<img style='border-style: solid; border-width: 1px;' src='/media/uploads/defaults/181'/><br/><br/>
<div class='imgCaption'>
Reverse Osmosis Caption
</div>
</div>
<pagebreak/>
<h3>Access </h3>
<h4>Type</h4>
<div class='content'>
Your plumbing system is accessible with a Main Shut off Valves
</div>
<h4>Location</h4>
<pagebreak/>
<h3>Operation & maintenance #1</h3>
<div class='content'>
All wastewater treatment systems and their components require regular maintenance.
</div>
<h4>Activity</h4>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}