import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h4>(?:(?!<\\/?h4>).)*?<\\/h4>(?!.*?<div class='content'>)";
final String string = "<div class='content'>\n"
+ " <img style='border-style: solid; border-width: 1px;' src='/media/uploads/defaults/181'/><br/><br/>\n"
+ " <div class='imgCaption'>\n"
+ " Reverse Osmosis Caption\n"
+ " </div>\n"
+ "</div>\n"
+ "<pagebreak/>\n"
+ "<h3>Access </h3>\n"
+ "<h4>Type</h4>\n"
+ "<div class='content'>\n"
+ " Your plumbing system is accessible with a Main Shut off Valves\n"
+ "</div>\n"
+ "<h4>Location</h4>\n"
+ "<pagebreak/>\n"
+ "<h3>Operation & maintenance #1</h3>\n"
+ "<div class='content'>\n"
+ " All wastewater treatment systems and their components require regular maintenance.\n"
+ "</div>\n"
+ "<h4>Activity</h4>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}