const regex = new RegExp('<h4>(?:(?!<\\/?h4>).)*?<\\/h4>(?!.*?<div class=\\'content\\'>)', 'gs')
const str = `<div class='content'>
<img style='border-style: solid; border-width: 1px;' src='/media/uploads/defaults/181'/><br/><br/>
<div class='imgCaption'>
Reverse Osmosis Caption
</div>
</div>
<pagebreak/>
<h3>Access </h3>
<h4>Type</h4>
<div class='content'>
Your plumbing system is accessible with a Main Shut off Valves
</div>
<h4>Location</h4>
<pagebreak/>
<h3>Operation & maintenance #1</h3>
<div class='content'>
All wastewater treatment systems and their components require regular maintenance.
</div>
<h4>Activity</h4>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}