use strict;
my $str = '<div class=\'content\'>
<img style=\'border-style: solid; border-width: 1px;\' src=\'/media/uploads/defaults/181\'/><br/><br/>
<div class=\'imgCaption\'>
Reverse Osmosis Caption
</div>
</div>
<pagebreak/>
<h3>Access </h3>
<h4>Type</h4>
<div class=\'content\'>
Your plumbing system is accessible with a Main Shut off Valves
</div>
<h4>Location</h4>
<pagebreak/>
<h3>Operation & maintenance #1</h3>
<div class=\'content\'>
All wastewater treatment systems and their components require regular maintenance.
</div>
<h4>Activity</h4>';
my $regex = qr~<h4>(?:(?!<\/?h4>).)*?<\/h4>(?!.*?<div class='content'>)~sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}