# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<h4>(?:(?!<\/?h4>).)*?<\/h4>(?!.*?<div class='content'>)"
test_str = ("<div class='content'>\n"
" <img style='border-style: solid; border-width: 1px;' src='/media/uploads/defaults/181'/><br/><br/>\n"
" <div class='imgCaption'>\n"
" Reverse Osmosis Caption\n"
" </div>\n"
"</div>\n"
"<pagebreak/>\n"
"<h3>Access </h3>\n"
"<h4>Type</h4>\n"
"<div class='content'>\n"
" Your plumbing system is accessible with a Main Shut off Valves\n"
"</div>\n"
"<h4>Location</h4>\n"
"<pagebreak/>\n"
"<h3>Operation & maintenance #1</h3>\n"
"<div class='content'>\n"
" All wastewater treatment systems and their components require regular maintenance.\n"
"</div>\n"
"<h4>Activity</h4>")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.