re = /<h4>(?:(?!<\/?h4>).)*?<\/h4>(?!.*?<div class='content'>)/
str = '<div class=\'content\'>
<img style=\'border-style: solid; border-width: 1px;\' src=\'/media/uploads/defaults/181\'/><br/><br/>
<div class=\'imgCaption\'>
Reverse Osmosis Caption
</div>
</div>
<pagebreak/>
<h3>Access </h3>
<h4>Type</h4>
<div class=\'content\'>
Your plumbing system is accessible with a Main Shut off Valves
</div>
<h4>Location</h4>
<pagebreak/>
<h3>Operation & maintenance #1</h3>
<div class=\'content\'>
All wastewater treatment systems and their components require regular maintenance.
</div>
<h4>Activity</h4>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end