package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ATC02007([0-9]{14})(_UFF_ACC)?.xls$`)
var str = `ATC0200720140828080610.xls
ATC0200720140901080346_UFF_ACC.xls`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}