$re = '/^ATC02007([0-9]{14})(_UFF_ACC)?.xls$/m';
$str = 'ATC0200720140828080610.xls
ATC0200720140901080346_UFF_ACC.xls';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;