import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{4}\\d{2}\\d{2} \\d{2}:\\d{2}:\\d{2}\\.\\d{3})\\s{1}-Fatal\\s{1}(.*?)(-\\s{1})*proce:\\s{1}(.*?)\\s{1}-\\s{1}pid\\s{1}(\\d{1,10})!!!$";
final String string = "20160803 14:34:49.748 -Fatal oomtotal-vm:862604kB, anon-r:179196kB, file-r:31604kBproce: qtbrowser - pid 2206!!!";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}