# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d{4}\d{2}\d{2} \d{2}:\d{2}:\d{2}\.\d{3})\s{1}-Fatal\s{1}(.*?)(-\s{1})*proce:\s{1}(.*?)\s{1}-\s{1}pid\s{1}(\d{1,10})!!!$"
test_str = "20160803 14:34:49.748 -Fatal oomtotal-vm:862604kB, anon-r:179196kB, file-r:31604kBproce: qtbrowser - pid 2206!!!"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.