import Foundation
let pattern = #"^(\d{4}\d{2}\d{2} \d{2}:\d{2}:\d{2}\.\d{3})\s{1}-Fatal\s{1}(.*?)(-\s{1})*proce:\s{1}(.*?)\s{1}-\s{1}pid\s{1}(\d{1,10})!!!$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"20160803 14:34:49.748 -Fatal oomtotal-vm:862604kB, anon-r:179196kB, file-r:31604kBproce: qtbrowser - pid 2206!!!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}