// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\d{4}\d{2}\d{2} \d{2}:\d{2}:\d{2}\.\d{3})\s{1}-Fatal\s{1}(.*?)(-\s{1})*proce:\s{1}(.*?)\s{1}-\s{1}pid\s{1}(\d{1,10})!!!$").unwrap();
let string = "20160803 14:34:49.748 -Fatal oomtotal-vm:862604kB, anon-r:179196kB, file-r:31604kBproce: qtbrowser - pid 2206!!!";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}