re = /^(\d{4}\d{2}\d{2} \d{2}:\d{2}:\d{2}\.\d{3})\s{1}-Fatal\s{1}(.*?)(-\s{1})*proce:\s{1}(.*?)\s{1}-\s{1}pid\s{1}(\d{1,10})!!!$/
str = '20160803 14:34:49.748 -Fatal oomtotal-vm:862604kB, anon-r:179196kB, file-r:31604kBproce: qtbrowser - pid 2206!!!'
# Print the match result
str.match(re) do |match|
puts match.to_s
end