#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)(.*?)(?:<div class="foo">.*?</div>|$)"
Local $sString = "<div class="foo">.*?</div>dfgdfg" & @CRLF & _
"sdfsdfsdfsd<div class="foo">.*?</div><div class="foo">.*?</div>saasdasdasd" & @CRLF & _
"" & @CRLF & _
"dfehrgerfsda<div class="foo">.*?</div>dsfdsfsdfdsf" & @CRLF & _
"<div class="foo">.*?</div>dfggdd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")