import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(?:<div class=\"foo\">.*?</div>|$)";
final String string = "<div class=\"foo\">.*?</div>dfgdfg\n"
+ "sdfsdfsdfsd<div class=\"foo\">.*?</div><div class=\"foo\">.*?</div>saasdasdasd\n\n"
+ "dfehrgerfsda<div class=\"foo\">.*?</div>dsfdsfsdfdsf\n"
+ "<div class=\"foo\">.*?</div>dfggdd";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}